Problems when uploading photos to a new place

I’m working on a piece about a new place, but unlike previously, the photos that I want to add won’t load (I’ve tried in vain by using my smartphone, home PC and work PC). Has anyone else experienced this problem recently?

What still works though is uploading/dropping pics to other users’ places.

The submission system is very broken atm, but they are fixing it slowly it seems.

What works for me is opening an incognito tab, going to AO, and logging in. It will ask you to accept cookies, press yes. (This is important). Then the system behaves better and lets you upload.
Another way is to save it as a draft and then add photos via the ‘add photo’s’ button, rather than the edited one. You can only do one at a time, but it works usually.

My current method is to make ~5-6 new places, give each photos and save them, then add text later.

Hope that that helps!

2 Likes

The advice about opening an igocognito window, while accepting cookies, worked perfectly! Tack så mycket!

1 Like

Glad to hear!